Kritická zranitelnost ve WordPressu

Byla objevena kritická zranitelnost v populárním systému pro správu obsahu WordPress verze 5.0.0, která umožňuje vzdálené spuštění libovolného kódu. Prakticky se jedná o kombinací dvou různých zranitelností (Directory Traversal a Local File Inclusion), pro jejichž úspěšné zneužití musí útočník získat v rámci instance WordPressu alespoň oprávnění autora. Tato nebezpečná kombinace zranitelností ohrožuje verzi WordPressu 5.0.0 a starší (údajně všechny verze za posledních šest let). Bezpečnější verze 4.9.9 a 5.0.1 (včetně 5.0.2 a aktuální 5.0.3) obsahují už "pouze" zmíněnou zranitelnost typu Directory Traversal, která sama o sobě není zneužitelná k vzdálenému spuštění nebezpečného kódu.

Ukázka provedení (PoC):