Critical vulnerability in Cisco IOS XE system

Filip Pokorný

Aug. 29, 2019

Cisco released patches for a critical vulnerability (CVE-2019-12643) with a CVSS score of 10. The vulnerability is due to an improper check performed by the area of code that manages the REST API authentication service. An attacker could exploit this vulnerability by submitting malicious HTTP requests to the targeted device. A successful exploit could allow the attacker to obtain the token-id of an authenticated user. This token-id could be used to bypass authentication and execute privileged actions through the interface of the REST API virtual service container on the affected Cisco IOS XE device. The good news is that the REST API interface is not enabled by default and must be installed and activated separately on IOS XE devices.